Wrong Ejector?

Discussion in 'P-3AT' started by jbabbler, Apr 30, 2010.

  1. jbabbler

    jbabbler New Member

    131
    Dec 27, 2008
    I lost the ejector for my P3AT and ordered one from Keltec. I called them, told them what I needed and gave them my gun's serial number. They sent me an ejector immediately and din't charge me (Great CS!). I installed the new ejector today and it drops in fine but the slide binds on it horribly. I can't even rack the slide past it. I assume that there are some generational differences with this part so which one did I most likely get and which one do I need? Could I file this one down? Thanks in advance.
     
  2. sviking

    sviking Banned

    68
    Apr 30, 2010
    Does it sit flush with the left side frame rail or does it stick up a bit? If it sticks up, then there's your binding. I'd just try to get another one from Kel-Tec.
     

  3. jbabbler

    jbabbler New Member

    131
    Dec 27, 2008
    Looking at the smooth side of the ejector (side that faces out from the gun) I can see that the lower portion sits ever so slightly higher than the base of the rail. 10 seconds with my dremel and the slide moves as smooth as new. I hand cycled 12 rounds through it and she ejected fine. I'll send a box of ammo through her this weekend and see how she performs.
    Thanks
     
  4. Sangueffusor

    Sangueffusor New Member

    May 13, 2007
    Indiana
  5. jbabbler

    jbabbler New Member

    131
    Dec 27, 2008
    Yeah, I saw that. Mine looks like the one in the picture. I circled the area that I had to shave down to make it work. It wasn't much material but it worked.

    [​IMG]