Community for Kel-Tec Shooters banner
1 - 10 of 10 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I just picked up my first KT this past Sunday. Tonight I finally got a chance to clean/fluff and buff. I can't get the slide to rack after I reasmbel it, what am I doing wrong? I'm sure it's something stupid. Thatnks for your help.

Scott
 

·
Registered
Joined
·
2,818 Posts
Take it back apart, when you reassemble make sure the assembly pin is through the cut out in the barrel lug. Just a guess.
 

·
Registered
Joined
·
5,028 Posts
Put ONLY the slide on the frame and see if that will go all the way back

If you can't put the slide on far enough to put the pin back in, that is the hammer needs to be reset

If it only goes back 1/8", that is when the barrel starts to cam down, did the barrel start to go down or go down. it could be the interface between the slide and the upper barrel lug needs lube.

try just the slide, no barrel no spring and get back
 

·
Registered
Joined
·
5,028 Posts
Take thumb and push it back like the slide would during recoil.  
Like cocking a revolver
It will click and stay

when it is reset, you will see the striking face
 

·
Registered
Joined
·
5,028 Posts
That is the reset position.

You said  you can push it down with thumb, so the slide going over should not be a problem there.

Now even with just the slide it takes a good amount of pull to go past the slide back 1/2"

Agin with just the slide, it should be easy to the normal battery position, then be easy for a 1/4", then it will require a hard pull to press the hammer down for about 3/4", then be easy for the remaining 1 1/4" travel

Put a dab of grease on thaat hammer face
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top