Community for Kel-Tec Shooters banner
1 - 10 of 10 Posts

·
Registered
Joined
·
239 Posts
Discussion Starter · #1 ·
I used that plastic ammo box that you gave me back in PA and the pin came out before I knew it.

Some will remember my horror story as I beat up my P3 trying to remove the pin to install my Armalaser.

The laser is acting awfully funny and is on it's way back to Rick.

Hopefully others can benefit from my ignorance on removing the frame pin!
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #4 ·
One moment it activates then nothing at the range. I get home and as I'm removing the screws it all of a sudden comes on (I leave it in the ready mode).

It's the first problem I've had. Rick received it back yesterday and will diagnose it today. He said it sounds like a loose sensor.

At first I thought it was the batteries but replaced those and had the same problem.

**Speaking of batteries: only two of ya'll have sent responed to my free Christmas batteries..I still have lot's of them if your interested!
 

·
Registered
Joined
·
116 Posts
Two Pistol Packer said:
I don't know if my PF-9 Armalaser will use the same batteries as the P3 one. Can you tell us, Rick?

Packer.
2PP, yes the PF-9 and the P11 ArmaLasers will use the same 357 cells as the P3AT version. In fact all the systems we make and the upcoming ones for the Springfield XD and Taurus Millenium series will use the same batteries because we standardized the laser module and electronics to be identical in all
versions. This way, if you sell a Taurus, for example, and buy a PF-9, you don't need to buy a whole new ArmaLaser, you can just send your old unit in and for $29 we will re-house it for you in the PF-9 housing. It makes switching between models easier and more efficient.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top