Community for Kel-Tec Shooters banner

1 - 20 of 24 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
My P17 cycles well, even with 1080 FPS ammo; however, the slide fails to lock back after last round, even with 1260 FPS minimags. I’ve fluffed and buffed and everything seems to work smoothly. The slide just won’t lock back after firing the last round. I can manually pull it back and it locks just fine. Any thoughts?
 

·
Registered
Joined
·
48 Posts
with a empty mag if you pull back the slide does it lock on it own not you pushing up the slide stop
 

·
Registered
Joined
·
146 Posts
There is a thread in here back a few months. Tells how to file a few thousands off in one location of mag. Author had same problem. this cured it.
 

·
Premium Member
Joined
·
4,690 Posts
It is almost certainly the magazine. Usually what it means is that the spring is not strong enough to push the follower up fast enough to engage the last round hold open (LRHO) before the slide moves forward again. There might be some drag inside the mag. First off get a silver paint-pen and number your mags. Then make sure that you are seeing the same thing with every mag or only with one or two. Once you've identified the suspect mag, take it apart inside a gallon freezer bag so nothing shoots off into space, never to be found again. Inspect the inside of the mag for anything which might be causing drag such as plastic mold flashing. If it's obvious, trim it off with an xacto. You might lightly sand inside the mag. Be careful not to change any dimensions. Some people like to use a dry lube such as a dry teflon which the carrier evaporates. Don't use oil because it attracts dust into the mag.

If none of this works, you might need to replace the spring. You might be able to contact Kel Tec or purchase a new spring from them. Worst case, you may have to buy a new magazine.

Peace favor your sword,
Kirk
 
  • Like
Reactions: SunshineJerry

·
Registered
Joined
·
10 Posts
Discussion Starter #15
It is almost certainly the magazine. Usually what it means is that the spring is not strong enough to push the follower up fast enough to engage the last round hold open (LRHO) before the slide moves forward again. There might be some drag inside the mag. First off get a silver paint-pen and number your mags. Then make sure that you are seeing the same thing with every mag or only with one or two. Once you've identified the suspect mag, take it apart inside a gallon freezer bag so nothing shoots off into space, never to be found again. Inspect the inside of the mag for anything which might be causing drag such as plastic mold flashing. If it's obvious, trim it off with an xacto. You might lightly sand inside the mag. Be careful not to change any dimensions. Some people like to use a dry lube such as a dry teflon which the carrier evaporates. Don't use oil because it attracts dust into the mag.

If none of this works, you might need to replace the spring. You might be able to contact Kel Tec or purchase a new spring from them. Worst case, you may have to buy a new magazine.

Peace favor your sword,
Kirk
Thanks much. I’ll give it a try. All three mags have the issue, but it does make sense.
 

·
Registered
Joined
·
958 Posts
I am just thinking out loud.

My slide locked back when new. Now I am getting some slide lock failures. I wander if it doesn't have something to with the tab that extends out the bottom as the.mag gets full.

We have have become used to loading the mag by settings units base on a firm surface. With theses mags initially I would push hard trying to get the last couple of rounds in the mag. That is until I would realize I had to lift the.mag to avoid putting excessive pressure on the mag spring and that tab.

Have I damaged the.mag spring or bent the tab?
I need to take the mag apart and check the tab for now.
 

·
Registered
Joined
·
32 Posts
Looks like P17 mags are $15 on Kel Tec's site. Might be worth picking up a new one and seeing if it functions. It would surprise me if you overcompressed all three of your mags that way, but it's possible.
 

·
Registered
Joined
·
28 Posts
Damn, what is with Kel-Tec Quality Control!. Seem like ever product line requires a file this, buff that to be semi-reliable.
 

·
Registered
Joined
·
958 Posts
Well I must admit I should have done this first. I have been enjoying shooting the p17 so much I hadn't cleaned it.

I took the bolt apart cleaned it and the rest of the gun.

Lock back on all mags.

These guns are so much fun and accurate. Great little gun.
 
1 - 20 of 24 Posts
Top