Community for Kel-Tec Shooters banner
1 - 3 of 3 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
What's up everyone im having trouble with my pmr30..when i try to manually racking the slide back to eject the the round,the 2 ejector/extractors DO NOT grab the round from the barrel..
I emailed keltec about a month ago and I AM NOW hearing from them...the hey told me to send the gun in to there repair department.
I'm just wondering for you guys who sent in your keltec. For warranty repair,did you have to pay for shipping or did they send you guys a call tag?
My pmr is still brand new and it was brought brand new about a month ago,the same they I emailed keltec and told them I had a defected pmr..
i remember 5 years ago when my plr16 needed work,they sent me a call tag no questions asked..
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #2 ·
BTW I did message them back asking for a call tag..im hoping I dnt have to wait another month to here back lol...atleast I have a brand new sub200p and a ksg to keep me company while I wait.
 

·
Registered
Joined
·
62 Posts
Discussion Starter · #5 ·
Ok guys they emailed me back asking for more info before they can send me a calltag..so i sent them the info they needed and im sure I would be getting a call tag..
They asked for a copy of the sales recipet,SN,date of purchace,if I'm orginal owner etc..
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top