Community for Kel-Tec Shooters banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2,095 Posts
Discussion Starter #1
Yesterday when I got my CA I fired 20 rounds through just to see how it did.. ran perfect..2 stock mags full...

This morning I tore it apart, cleaned it all up, polished the bottom of the bolt carrier and set up out in my drive (50 yards, thats the kinda part) and went to do some more testing..with targets even this time..mild wind,a stock mag, a 20 round Pmag, and a 30 round Pmag with the window in the side. 55 gr PMC, and 64 gr reloads I allready had.
...The gun performed flawlessly except 2 FTF's...the last two in the stock mag while sighting in..put the mag in with just the two and both failed to fire..hmm..started thinking about it and when I let loose of the bolt while chambering I kind of followed it with my hand, slowing it down...put the two back in the mag,pulled the bolt back and let loose of it..bang bang.. both worked just fine..I think my fault for slowing the bolt down upon loading.

So I had a perfect performance with the stock mags, and both Pmags..got the gun sighted in (just at 50 yards for now), here is a pic of my last firing session, this is 55 gr PMC's off a "loose" rest with a fairly rapid fire with the 20 round Pmag, my old eyes and the stock Iron sights..I'm reasonably happy with the results..Cant wait for a quiet day at 100 yards..(the 2 at the bottom off the target dont count, they were from earlier forgot to spot them)..

\\
 

·
Registered
Joined
·
152 Posts
Good report A.O. The bolt will work it's way to a smoother action the more you shoot it. I like to use the bolt handle like a forward assist on a AR especially on a tight full magazine to make sure the bolt is locked.
Nice shooting by the way :)
 
1 - 2 of 2 Posts
Top