Community for Kel-Tec Shooters banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello i have a problem my plr 16 broke on me in its jams from time to time is there any website that u know that can take care of this problem for me...
 

·
Super Moderator
Joined
·
9,973 Posts
Hello i have a problem my plr 16 broke on me in its jams from time to time is there any website that u know that can take care of this problem for me...
I suggest you call Kel-Tec customer service and discuss it with them. Their number is in the PLR-16 FAQ. The FAQ also has some troubleshooting info if you're interested.

http://www.thektog.org/forum/showthread.php?t=205038
 

·
Registered
Joined
·
3,067 Posts
Hello i have a problem my plr 16 broke on me in its jams from time to time is there any website that u know that can take care of this problem for me...
Jams can be caused by *anything* --- bad magazine, bad springs, dirty gun, crappy ammo, messed up gas system, and more. What exactly broke? What have you done to narrow down the problem (tried different mags? different ammos? cleaned the gun? ??)
 

·
Super Moderator
Joined
·
9,973 Posts
That's a rare failure mode. Apparently, your piston rod wasn't properly staked into the bolt carrier.

Call Kel-Tec (number is in the FAQ). If it's a relatively new PLR-16, you should ask for a shipping label so you don't need to hassle with shipping it yourself.

Kel-Tec will take care of you.
 

·
Registered
Joined
·
3,067 Posts
um, yea, that one is going to take professional care. A lil epoxy or duct tape is right out this time. Sorry to see that happen to you, but its beyond table top repair work.
 

·
Registered
Joined
·
389 Posts
That's a rare failure mode. Apparently, your piston rod wasn't properly staked into the bolt carrier.

Call Kel-Tec (number is in the FAQ). If it's a relatively new PLR-16, you should ask for a shipping label so you don't need to hassle with shipping it yourself.

Kel-Tec will take care of you.
Do you think this is done by reassembling wrong or something just going wrong?
 
1 - 9 of 9 Posts
Top