Community for Kel-Tec Shooters banner

1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
On the second-to-last-round of every magazine load, I get a failure to feed. It jams the bullet into the upper edge of the chamber and crease the nose on my Federal American Eagle FMJ.

All other rounds before and after this one in the magazine work fine, just the second-to-last jams EVERY time.

While jammed, if I rap the slide, it finishes feeding the round and works fine.

I have only the magazine that came with it, or I'd test it with another one. Magazine spring tension or something?

Any ideas on how to fix it?
 

·
Registered
Joined
·
0 Posts
Because of the consistency of it I think it sounds like a mag issue, but before we condemn the mag you should try the F&B or at least polish the feed ramp to see if the helps the concern. It also could have a weak guide spring but I don't think so b/c of the consistency.
 

·
Registered
Joined
·
186 Posts
Have you disassembled and cleaned the mag?  Also, maybe the mag spring is in backwards and the follower at that point isn't in the correct position.  Those are my only ideas  :-/
 

·
Registered
Joined
·
1,267 Posts
rhinokrk said:
Have you disassembled and cleaned the mag?  Also, maybe the mag spring is in backwards and the follower at that point isn't in the correct position.  Those are my only ideas  :-/
plus one. check and clean the mag.
 

·
Registered
Joined
·
4,879 Posts
Get another magazine. Most likely a new mag won't have this problem but you need to be certain whether it's the mag or the gun. That said, my minimum number of mags for my guns is three. That way if one of my mags goes bad, my guns are out of commission until I can find another mag. It also means that, heaven forbid, if my mag fails in a gunfight, I'm not left defenseless. With at least another mag, I can drop it and reload. But, I also make sure I have a BUG on me unless the way I'm dressed won't permit that. That way I have a second gun. should my primary fail.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
rhinokrk said:
Have you disassembled and cleaned the mag?  Also, maybe the mag spring is in backwards and the follower at that point isn't in the correct position.  Those are my only ideas  :-/
I'll clean it out this weekend. Thanks for the idea!
 

·
Registered
Joined
·
1 Posts
I started having the exact same problem today ( ftf on second to last round). This happened w/ Blazer (7 out of 7 magazines), and American Eagle ( 1 magazine out of 7) in both of my two new magazines .

This is a new hard chrome p3at (purchased two weeks ago). I put 200 trouble free rounds through it last week (Winchester White box, PMC Bronze, Hornady CD) for break in. Polished ramp with jewlers rouge/dremel.Gun clean and lubed up.Mag springs installed properly. Totally clean mags. This is not my 2nd p3at so I'm familiar with limp wristing issues.

Could this simply be incompatible ammo? Would the stronger Wolf mag springs help? Did you find a solution HeavyHawk?


Thanks!!!!!
 
1 - 9 of 9 Posts
Top