Community for Kel-Tec Shooters banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello all, Just got a new P-3AT in hard chrome. Cleaned and lubed it tonight and noticed this hole just behind the rear sight. We have 3 of these in the family and this is the only one with it. Not sure if it is a concern or not? I also had a small piece of plastic fall out of the mag well that looks like it came from the Mag release catch, but I read on here that part takes a beating, didn't expect that to happen so soon. Read some older posts that someone on this forum sells a metal one? Does Kel-tec make one yet?
Thanks in advance,
Gerry
 

·
Registered
Joined
·
718 Posts
That looks like it was cut way to deep to me. I would call KT and have a new one shipped ASAP or take back to the dealer. It should shoot just fine but it's not supposed to be there. Someone was asleep in QC that day.
 

·
Registered
Joined
·
5,028 Posts
welcome to KTOG and congradulations on your p3at.  I think that is the FIRST one that has posted where the machining tolerance have cause a break through at the rear sight.  while it will not hurt any thing, that is a maching error.  there is ususally a break through on the bottom of the slide where the pin of the extractor fits.  
my self, I would keep that slide. I have been thinking about removing the rear sight and extending the groove farther down and figured I would have a similair break through because of the way the inside of the slide was cut

as for shearing off a piece of the mag catch, that will cause a problem if that is where the plastic came from

sorry for the not so good news
 

·
Registered
Joined
·
898 Posts
Welcome to KTOG!

Sorry to read that you're having issues with your P3AT. Sure wish Kel-Tec would make a metal catch, a MIMed one would work just fine and be much better than the polymer catch. Last time over on the Trading Post forum I saw that metal catches are available for purchase. However, I believe you need 25 posts in order to use that forum.

Take care,
Bill K.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Thanks for the replies. More bad news. Went to the range with the gun in this post and a Freedom P3AT that had 200 rounds through it. Mine right out of the box after 2 mags had FTE's, sometimes multiple ones in 1 magazine. Mostly did it when the magazine was topped off after chambering a round. The Freedom one started doing this last trip to the range. I noticed that both guns extractor springs had worked loose, my brand new one only after 2 magazines. Ill have to do the loc tite. Cant believe they leave the factory this way. I emailed kel tec and asked for an address where I can send the pic of the hole in the slide, so I wont bother shooting it again until I get an answer on that. The machining in that area is cut much deeper than a normal slide.
 

·
Administrator
Joined
·
32,132 Posts
I've never seen one like that.  Could be the little tab of metal was closing the hole at some point and it might have come out after test-firing at the factory, during shipping, at the gunshop, etc.  Assuming that is what you want, Kel-tec should exchange the slide for you pretty quickly.  When contacting Kel-tec, it's usually best/fastest to just give the service department a call.
 

·
Registered
Joined
·
380 Posts
I had a loose extractor spring screw on mine too after ~175 rounds. FTEs might have been that, might have been the 175 rounds that dirtied the gun. Next time I shoot, I'll run some through and see if it slacks off again. I just tightened it up, no loctite.
 
1 - 7 of 7 Posts
Top