Community for Kel-Tec Shooters banner
1 - 8 of 8 Posts

·
Registered
Joined
·
238 Posts
Discussion Starter · #1 ·
Took my 4th new p3at to the range today and fired around 100 rounds threw it various brands od JHP and FMJ no jams at all, but after i had fired around 25 rounds, 3 times out of 75 shots  when i pulled the trigger the hammer seemed to drop but the bullet did not fire, about 4 seconds later the bullet would ignite. good thing i kept the pistol pointed downrange,i have never had this happen before with any gun i have owned. it occurred to me perhaps something was delaying the firing pin perhaps a metal partioce from the factpory, this gun   came with a hard chromed slide, i will take apart when i get home and check trhe channel out, this happened only with PMC FMJ ammo, came from a new  2 boxes, any ideas why else this would happen?other then that it shot fine no jams or ftfs.. Forgot to say this is a new hard chromed P3at sn KKQ1//. and slide was dry as a bone, unlike others i have owned, i oiled it prior to shooting, this is a bu gun for me and i need same to work right, i have owned 3 other p3ats nevera prob.....
 

·
Registered
Joined
·
5,028 Posts
You might need to contact "Q". I am all most positive I saw the delayed firing option used by James once ;D
 

·
Registered
Joined
·
5,028 Posts
Yes, having a misfire like that can be very unnerving. I have had what was probably less than a second delay with rifle reloads that seemed like several seconds.

It will be intersting if you could have noticed if the hammer truely came back and fell properly on the firing pin

Or did hammer fall on the block, then slipped off of it, stricking the FP
 

·
Registered
Joined
·
238 Posts
Discussion Starter · #4 ·
ok i just got back from shooting 50 more rounds through the p3at, deleyed fire only happened once. but still. unnerving is not the word for it, for got to post this initally, i took the fp out clkeaned the channer and checked the spring akll seemed ok....my han d is ghetting sore, i am also breaking in a new pf9, no prpobe whatsoever with it,,,,great pistol, ill attempt to shoot the p3at tomorrow and see what happens, it reminds me of holding a firecracker in hand after lighting the fuse....lol
 

·
Registered
Joined
·
5,028 Posts
If you have a snap cap, have you though about just dry firing a bunch of times and carefully watching the hammer
I think I would even use a spent case since you are having this problem

I was "taught" to hold on target and count to 10 for such misfires. With todays training to immediately to rack and tap on a mis fire could have been bad

I would think the problem is more likely ammo
 

·
Registered
Joined
·
238 Posts
Discussion Starter · #6 ·
i thought it was ammo as well but several diff boxes of pmc bronze fmj range ammo,  and i golden saber, all new ammo, i shudder for some reason i did not do what i usually do and turn the gun sideways to rack it, could have shot the fellow next to me,but after the 2nd one i waited a while....u r right about the rack and tap senereo....i will say that of all the kel tyec pistols i have owned i have had very good luck, had to send a p40 back years ago for a goof i did to the gun, but they fixed it , all new top end for nc and it was fine aftyer that..
 

·
Registered
Joined
·
121 Posts
Are you trying ammo from the same store? Maybe one of their shipments got contaminated by something. I heard solvent can erode gunpowder.
Ammo seems the likely source for the trouble. I would keep test firing ammo bought at different stores. If the problem persist, contact kel-tec!
 
1 - 8 of 8 Posts
Top