Community for Kel-Tec Shooters banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I bought a G27 & P3-AT at the same time last month. Both fired without a hiccup but my P3-AT would not go into battery when I chambered a round. I had to push on the rear of the slide. Hopefully it's only a break in issue, otherwise a fluff & buff is in order. I'll put a few hundred rounds more through it before I start that.
 

·
Registered
Joined
·
5,028 Posts
Congrates on finding the HC (don't know any thing about the other one to say ;) ).

The shove on chambering is a normal out of the box complaint. I would reccomend a clean and lube after only 20 to 30 rounds to help speed up the breakin and prevent the aggrovation of other hangups. when cleaning, pay attention to the frame rails, especially back of the magazine well, oppositie the ejector and the front of the frame. if there is any raised metal, smooth it back down.

and a thicker lube helps. a lot here swear they need a dab of grease on certain spots.
 

·
Registered
Joined
·
3,755 Posts
Texas47 said:
I had to push on the rear of the slide.
A minor Fluff & Buff along with a thin film of Slick 50 One Grease (excellent for wheel bearings) in the appropriate places will speed-up the break-in while making range time more enjoyable.

Wilson – who’s a Hard Chrome P-3AT aficionado :)
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top