Community for Kel-Tec Shooters banner
1 - 4 of 4 Posts

·
Registered
Joined
·
147 Posts
Discussion Starter · #1 · (Edited)
Hey all,
I was able to get out to the range today for the first time in a while and decided to do a general mag test with all the various magazines I have been buying while sitting around. I was surprised by some and disappointed by most of the mags that I had high hopes for. I did all the tests in my Gen 4 G19 (Lone Wolf, Alpha Wolf Barrel) and my Keltec Sub2000 (no mods that would affect mags/shooting). So lets get started...


  • SGM Tactical 31rd mag (w/ +2 extension):
- **Glock**: Locks in fine. Drops free fine. Shoots and cycles well. Only one cycling problem out of about 50rds.
- **S2K**: Locks in fine. Drops free fine. Shoots and cycles well. No FTF/FTE.
- **Notes**: I had high hopes for this and it only failed with one round. So pretty good.


  • KSI 31rd Mags (w/ +2 extension):
- **Glock**: Locks in fine. Drops free fine. One worked well with no FTF/FTE. One didn't work at all.
- **S2K**: Lock in fine. Hard to get out. Both cycled well. No FTF/FTE
- **Notes**: I have to get a silver sharpie and number these so I can test them properly and find out what wrong in both. I will clean both and retry. I think I tried lubing the spring in them for some reason, so that may have caused a problem.


  • Surefire 31rd Mag (w/ +2 extension):
- **Glock**: Locks in fine. Drops free fine. Problems cycling. Various FTEs. When I only filled it with 10 rds is had zero problems.
- **S2K**: Locks in fine. Hard to get out. Cycled well. No FTE/FTF.
- **Notes**: Nothing significant. I have to do more testing with magazine at capacity and with only several rounds loaded to see what the problems are with the Glock and this mag.


  • ETS 31 rd Mag:
- **Glock**: Locks in fine. Drops free fine. Hard to get a round chambered. Constant FTEs. When I only filled it with 10 rds is had zero problems.
- **S2K**: Locks in fine. Hard to get out. Cycled well. No FTE/FTF.
- **Notes**: Nothing significant. I have to do more testing with magazine at capacity and with only several rounds loaded to see what the problems are with the Glock and this mag.


  • SGM 50rd Drum Mag:
- **Glock**: Doesn't lock in unless slammed in. When slammed in it will not feed at all. I think the mag goes up too far. When not fully locked in it feeds and shoots perfectly fine. I just have to use the neck of the mag as an extra finger hold to keep it in the mag well.
- **S2K**: Locks in fine. Hard to get out. Cycled well. No FTE/FTF.
- **Notes**: I may have to work on the mag lock to get it to function properly in the Glock. Other than that issue it works fine. I didn't do a complete mag dump yet, so it may or may not work well with that.


  • ETS 17rd Mag:
- **Glock**: Lock in fine. Drops free fine. Cycling problems when at capacity. Cycles fine with only 5-10rds in. FTE at capacity.
- **S2K**: Locks in fine. Very hard to release. Cycles fine. No FTE/FTF.
- **Notes**: Nothing significant. I have to do more testing with magazine at capacity and with only several rounds loaded to see what the problems are with the Glock and this mag.


  • PMAG 17rd Mag:
- **Glock**: Locks in fine. Drops free fine. No FTF/FTE.
- **S2K**: Came with this gun. Locks in fine. Drops free fine. No FTF. One stove pipe.
- **Notes**: Nothing significant. Works well.


Overall assessment: Besides the PMags and Glock factory mags every aftermarket mag had problems being removed from the Keltec. I'm not exactly sure why, but I will test further. This was the first time firing all of these mags (besides the PMag), so it may be just "breaking them in" in terms of not cycling well in the pistol. I didn't try them with the factory barrel either, so that may be an issue. None of the mags affected group size. The drum made everything shoot a bit high because of the weight and the way I had to hold it.

Once I get some good deals on ammo I will do some mag dumps on these to see how well the cycle under higher rates.
 

·
Registered
Joined
·
147 Posts
Discussion Starter · #3 ·
One question for ya, EP ~ did you load 'em to capacity & let 'em sit awhile before testing?
Yes. All were loaded to capacity about a month ago. All sit unloaded now.

I did not record what ammo was in what mag when a failure happened. I was using PMC Bronze, American Eagle, and Winchester bulk pack. All 115 gr.

I did notice that, on the first round shot after sitting the S2K down, I could feel the bolt ride back and forward as if it were in slow motion. This didn't happen every time, but a few times. No FTF/FTE during that cycle though.
 

·
Registered
Joined
·
670 Posts
Check 'em

Yes. All were loaded to capacity about a month ago...
With that out of the way, I do remember a mention about the aftermarket mags occasionally binding. IIRC, the mold lines inside were the culprit. If it's not too much hassle, pop-off the base plates & inspect inside to see if they require some smoothing. Let us know how it works out ;)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top