Community for Kel-Tec Shooters banner
1 - 5 of 5 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
I have to mags, not sure which one came with and one one I bought. I have NAA ext. on both and one of them goes in fine, hold the button down and slide in with 6 + 1. the other requires either slamming the mag or pushing the button in and applying far two much pressure. Any fixes? Possibly NC mag catch?

Justin
 

·
Registered
Joined
·
5,028 Posts
Is the problem with loaded magazines?
It could be the spring going solid. If both mags have the extension, then compare spring number of coils. It could also be one spring is not seated proper on the base or in the follower

See how they install when unloaded. then load the hard to install one with one less round and compare.

I know when I load mine with 6 it is harder to install than with 5.
 

·
Banned
Joined
·
7,638 Posts
That's good advice that JFB gave you. If you don't find any of those problems:

Try fully loading and unloading the mag about 10 times. Then leave it fully loaded overnight. That should help.

Packer.
 

·
Registered
Joined
·
58 Posts
Interesting.
???I just got my gun back from being ported (love it) and the round from a loaded magazine will not chamber. It jams about 1/8" out of the magazine on the front upper part of the magazine well. The magazine is seated fully, and the spring appears to be in properly It is a newly purchased magazine (they inadvertently kept my old one). Any ideas?
 

·
Banned
Joined
·
7,638 Posts
  The magazine you got with your gun was already broken in by being filled several times during test firing. You will now have to break in the new magazine.

  Keep it filled overnight. Then try shooting a few mags with one less in the mag to start with. It should get better as you use it.

Packer.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top