Light Primer Strikes

Discussion in 'P-3AT' started by Larz, Apr 26, 2009.

  1. Larz

    Larz New Member

    6
    Feb 12, 2009
    I have about 200 rounds through her and a few weeks ago I had a dud at the range....at first I thought it was the ammo....today....same thing....tried my carry rounds Golden Sabre and had the same results. Going to call Kel-Tec in the AM, but it's not the ammo.
     
  2. ChasF

    ChasF Member

    270
    Feb 14, 2009
    Is there a firing pin mark on the primer at all?

    In another pistol that I own I have had no strikes on the first round loaded from a mag several times. I'm not exactly sure what is causing it, but for some reason the round fed by 'hand' doesn't fully lock the breech. So the energy/momentum of the hammer strike is seemingly taken up by moving the slide some fraction of an inch forward. So far my fix has been to slingshot the slide and tap the back of the slide with my palm. That seems to have provided a temporary respite from the problem. I did a feed ramp polish on that pistol, which solved many feed problems, but I'll be doing a chamber polish in the very near future in hopes that it will help this one.

    Oh, I figured out that it wasn't a firing pin issue when I noticed that a) there was no firing pin mark on the primer, and b) that it only occurred on the first round manually loaded. Hopefully you have noticed a uniqueness about when the no-fires happen so you can tell the service personnel about that - it may help lead to the correct solution.
     

  3. JFB

    JFB New Member

    Jul 25, 2005
    Thanks for the reminder...
    i haven't cleaned my firing pin this year. ::)
     
  4. Larz

    Larz New Member

    6
    Feb 12, 2009
    Yes
     
  5. bro61

    bro61 New Member

    305
    Sep 13, 2008
    I would disassemble and thoroughly clean the firing pin, spring and channel. Then shoot it again before doing anything else.