Community for Kel-Tec Shooters banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello everyone. I have just recently purchased this great gun but am having difficulties reassembling the stock. The stock gets hung up at a certain point and wont push in any further. I tried all I can think of. I removed the bolt to show pictures of what's going. It looks like the plastic little lip things that slide in at the very tip of the stock middle piece has some wear on it. It's kinda hard to see but it's on the last picture. Is my stock crooked and not allowing it slide in and does it need to be sent back to be fixed? Or has anyone else had this issue and know what I'm doing wrong or have a fix?
1553658707808692317531406429354.jpg
15536587477547769540814744013600.jpg


15536588220858277204664717358967.jpg
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I make sure its lines up in the cut out onthe bolt carrier. Then slide it in till i hear a little *click. Then I take the stock and slide it in while i lift on the firing pin. Still Gets stuck just about half an inch from closing all the way and lining up with the cutouts to insert the pins. I'm so frustrated ): I really wanna go shoot it this weekend.
 

Attachments

·
Registered
Joined
·
5 Posts
Discussion Starter #4
From memory... check the position of the shell lifters and/or

at about 5:30

at about 4:30
I used this videos as guides as well and they make it seem so effortless. Doing both of their methods. I dont get what's being so difficult.
 

·
Registered
Joined
·
238 Posts
Maybe rotate it so it's a slightly different angle when reassembling?

I remember mine getting a bit hung up the first few times i took it apart.
 

·
Registered
Joined
·
238 Posts
Just checking to see if OP got things back together.

I had to field strip mine at the range yesterday (long story) and when reassembling I had a similar jam where the OP did.

To get the butt all the way in I just lifted up a little on the firing pin and it slid right in.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Just checking to see if OP got things back together.

I had to field strip mine at the range yesterday (long story) and when reassembling I had a similar jam where the OP did.

To get the butt all the way in I just lifted up a little on the firing pin and it slid right in.

Hey, thanks for checking up. I've tried different ways to get it in there which i feel has been hundreds of attempts lol. I'm moving to a new home and will just send it in to Kel tek to have them fix it. They have life time warranties to my knowledge and it just doesn't seem right for it to be this difficult.
 
1 - 10 of 10 Posts
Top