Hope the Honeymoon is not over!!!

Discussion in 'P-3AT' started by fas111, Sep 24, 2010.

  1. fas111

    fas111 New Member

    25
    Aug 28, 2010
    Well I got my P-3AT on August 28th. I have been to the range 3 times and fired or should I say attempted to fire 3 boxes of factory ammo. I box each of Magtech, Blazer Brass and Speer Lawman. All RN FMJ 95 grain. Today I fired 35 rounds and got 9 failures to extract using the Blazer and Speer ammo, I was all out of Magtech but it too FTE. The little guy has been carefully cleaned and lubed each time it visited the range and it has always FTE . The stoppages are difficult to clear due to the lack of a slide holder. I came home and called Kel-Tec and they want me to try a new ejector which is being mailed today. Anything special I should know about installing it? Once I remove is anything going to fall out other than the ejector? I really enjoy this forum and have learned a lot from you guys.
     
  2. HOUSER52

    HOUSER52 Active Member

    144
    Jun 17, 2010
    A new extractor will probably get you going.

    Remove the extractor screw. When removing and reinstalling the screw that holds the extractor spring be sure not to strip out the head or you'll need a new one.
    When it's removed the spring and extractor will just fall out. Watch for the ejector it might or might not fall out but mine never has. While you're at it remove the firing pin and FP spring from the back of the slide, check for burrs, clean and lightly lube. Clean the firing pin channel and where the extractor goes. Lightly lube.
    Put the firing pin and spring back into the hole making sure to line up the flat part of the pin with where the extractor spring screw will be. Put the extractor, extractor spring and screw back into place and while pressing in on the firing pin tighten the screw down snug. Use blue loctite or another removeable thread locker on the threads to keep it from working loose. ( Very important )
    I might have forgot something but I think that's it and you're done.
     

  3. JFB

    JFB New Member

    Jul 25, 2005
    Have you looked in the P3AT FAQ/VIP thread?
    http://www.ktog.org/cgi-bin/yabb2/YaBB.pl?num=1204773333

    there is a link titled
    Quote from Big_Bear on Mar 21st, 2006, 4:41pm:
    ..an easy way to disassemble a P3AT 2nd gen. slide?


    Clicking on the "Quote from" on the link in the FAQ/VIP will take you to the tread in which details it greater than it ever needed to be ;)
    http://www.ktog.org/cgi-bin/yabb2/YaBB.pl?num=1142990160/0#0
     
  4. buckeyedave

    buckeyedave Member

    77
    Jan 1, 2010
    I had the same problem but all I did was tighten the exisiting extractor and it worked like a charm. Try that first.
    Dave
     
  5. fas111

    fas111 New Member

    25
    Aug 28, 2010
    You guys are the best!!! I did try to tighten the little bugger but it did not make a difference. I am looking forward to new part and the great advise I am getting from this forum.
     
  6. JFB

    JFB New Member

    Jul 25, 2005
    while the firing pin is out, clean the channel
    and check the hammer end of the firing pin for mushrooming. filing a slight champer helps
    [​IMG]