Community for Kel-Tec Shooters banner
1 - 4 of 4 Posts

·
Registered
Joined
·
357 Posts
Discussion Starter · #1 ·
I cleaned the P-3AT today - was happy - had just put 100 rounds through it with NO FAILURES - this is the first time since getting it back from KT that it has not had some problem -

I was considering promoting it up to a BUG.

I was inspecting the slide to make sure it was totally clean and I thought I saw a chunk of crud on the bottom of the slide - between the lug and the rail - when it would not wipe off I took a closer look -

ITS A HOLE. Its about the size of a toothpick - but in a 1/2 moon shape.

Anyone else have a hole in their slide?

The peening issue is starting to show its ugly face again also - I just hit 300 rounds total (on this slide)

Since it shoots fine - I think I will just wait - see if the peening gets worse - then maybe do a credit card swap.
 

·
Registered
Joined
·
5,028 Posts
That half moon hole is where the bore for the extractor pin fits has broke through. It will prevent the build up of cleaning fluids and oil
 

·
Registered
Joined
·
3,755 Posts
z71bill said:
ITS A HOLE. Its about the size of a toothpick - but in a 1/2 moon shape. Anyone else have a hole in their slide?
Don’t pick at it and it will heal.

Wilson – who’s remembering his childhood days :)



PS All but a few of my second-generation P-3ATs have that same hole
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top