Community for Kel-Tec Shooters banner
1 - 5 of 5 Posts

· Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Hi guys, second post here. Got to shoot my new 2nd gen 3at this weekend. Actually had 4 buddies all put a few clips through it. We each managed to have this happen to us and now I can make it happen "on command". If we didnt pull the trigger, hard and fast, then the hammer would cock, release, and got blocked again by the hammer block before hitting the firing pin.

I have read many times that you can "stage" the trigger on this gun, pull it ~3/4 of the way until you feel it about to give and then pull it the rest to get a slow and accurate pull on the trigger. If I do this, the hammer wont hit the pin, stops short.

Am I weird? Doing something wrong? Thanks!
 

· Registered
Joined
·
27 Posts
Discussion Starter · #7 ·
Thanks for the suggestion, it is not the pin, it looks like the reference pictures and cannot be pushed in any farther.

I have uploaded a 20 second video of the problems I am having.  First 2 pulls shown are slow, second 2 are fast.  

[ame]http://www.youtube.com/watch?v=Gx_dxE3dbv0[/ame]
 

· Registered
Joined
·
27 Posts
Discussion Starter · #10 ·
/\ it has gotten worse, takes about 6 trigger pulls for the hammer to finally strike the firing pin now. Taking it to the retailer now who offers a 1yr warranty on all guns, hopefully they fix or replace it and dont send it to KT for the next 2 months. After all I bought this gun for summertime carry!
 

· Registered
Joined
·
27 Posts
Discussion Starter · #11 ·
The gun shop tore it all apart today, couldnt figure out what was wrong so they are sending it back to KT. They said on average they service them in 2 weeks so we will hope thats the case!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top