Community for Kel-Tec Shooters banner

1 - 5 of 5 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
bold locked open, insert full 30 rd p-mag, drop bolt and the round will not fire, cycle the bolt ejecting the first round and everything is fine, put first round back in mag and will fire.
 

·
Registered
Joined
·
9,377 Posts
Just load 28-29 rounds?

Seriously, it was SOP with the M16 in Vietnam to load the mag full and strip out two rounds.
Still today, 30 round mags are really 28 round mags at my house.

That allows a full mag to be seated with the bolt carrier foreward.
It also takes first round pressure off the bolt carrier for more positive feeding.

Anyway, my guess is, the bolt was slowed enough by the full mag pressure it didn't fully lock into battery.
Next time whack the bolt handle when you load and make sure it is truly locked shut.

rc
 

·
Registered
Joined
·
64 Posts
Discussion Starter #4
everytime, probly right about full mag pressure on the bolt, never thought of that, thanks.

I got no prob with 28 or 9 rounds if it works.
 

·
Grand Poobah
Joined
·
1,366 Posts
rcmodel is probably exactly right about what's going on. You mentioned using the P-Mag. These are known to work very well with these guns. You might check the bottom of your bolt for rough spots or burrs that might be rubbing the feed lips or the next cartridge. If this is a new gun, it may get better on break-in. Mine shoots from full 30-round mags. I polished the bolt on it and it helped reliability. If I were using my PLR-16, or AR-15, for defensive purposes, I would consider downloading a round or two as well.

buzzsaw
 
1 - 5 of 5 Posts
Top