Community for Kel-Tec Shooters banner

1 - 3 of 3 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
If anyone is having failure to fire problems. What I believe you need to do is look at your fired or unfired cartridge. If the firing pin is not striking in the center of the primer, if it is hitting of to the side you have a slide issue. The firing pin channel has been drilled incorrectly. You need a new slide. I went through this problem. After replaceing my slide i have fired 400 trouble free founds. All different brands of ammo. Call mike at keltec. You will have to send your slide in first and he will send you a new slide. 8 day turn around and the gun is awesome.
 

·
Registered
Joined
·
5,028 Posts
thanks for the update,
kmunch said:
dateI just boughrt my second P3AT and it misfires alot It is like the firing ....
Did you by chance get any pics of your off center cases or slide.
I wonder if you noticed was it off left/right or up/down?
with CNC machine spitting out slides, it could be possible a few more from that machine got out
Do you mind posting the first digits of the serial #?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
I cant tell where it was hitting off Because I have a new slide. But if its not hitting center you have a problem. My gun is at my office I will check the number and post it later. The problem is keltec starts with the firing pin the sends a hammer spring and the gets to the slide. Unless the firing pin is bent then you have a slide problem. Like I said before I have not had a single problem since the new slide. LOVE my gun NOW
 
1 - 3 of 3 Posts
Top