Community for Kel-Tec Shooters banner
1 - 4 of 4 Posts

· Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
For the first time, using ammo that I have never used before in the 3AT(Sellier Belloit), several cartridges failed to fire--I heard the click of the trigger and the firing pin but "nothing". Looking at cartridge after ejecting, I noticed a slight "dent" in the cartridge, where the pin actually hit the cartridge but it just did not result in a discharge. Asked someone in the gunshop and was told that with the 3AT and its "soft" (I think that was the word) pin, sometimes cartridges can fail to fire. Everything else I tried today (we are now talking about the good stuff--Federal hydra, and speer gold) fired fine. As a matter of fact I reloaded several of the cartridges that did not fire the first time into the mag and they fired this second time. Other S&B cartridges in that box also fired on the first try. Explanations? Comments? Interested in others with similar experience and reasons for same.
 

· Registered
Joined
·
54 Posts
Discussion Starter · #6 ·
thanks guys. from the replies it would seem that S&B is not made for my 3, which seems to have been the case with others. Some of it worked so I got my money's worth. It was available and with 380 practice ammo being rare, it helped a bit. Again, thank you for your replies.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top