Community for Kel-Tec Shooters banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
After about 30 rounds through my new GEN 2 P3AT the trigger lost tension and was easily pulled back with no round firing. A second pull on the loose trigger fired the round. No FTF problems. NO FTE problems. I thought maybe being Left handed I may have been pushing on the Mag release. I don't think this is the problem. I put 150 rounds through it and experienced this about 10 times. I was thinking I may have been pulling back with a little side pressure instead of "straight" back. i always gave the Mag a tap to be sure it was lined up...also tapped back of slide to be sure. I have not seen this in any of my other guns. Has anyone seen or heard of this glitch??
 

·
Registered
Joined
·
5,028 Posts
moabmike said:
..the trigger lost tension and was easily pulled back with no round firing.

A second pull on the loose trigger fired the round. ...
Could you be "short stroking" the trigger. That is you MUST let the trigger be COMPLETELY released.

IF you release trigger to the first click and try to pull you again, that is short stroking.
depending on how new your pistol determines if you have the original hammer block or the new. I'm thinking you have the new.

with the old hammer block, if you short stroke, the hammer will fall from an intermidate stroke with out enough force to fire a round and then requires racking the slide to reset the hammer.

with the new hammer block, if you short stroke, ( I do not have one and only from what KY says) nothing happens, BUT if you then completely release, it will fire. Thus It sounds like you are short stroking


NOW there is another problem it might be. that would be the plastic pin driven in behind the trigger is lossing engagement with the trigger axis. the sysmptoms are more that you have to pull EXTRA hard at the end of trigger pull to make it fire. If this is it You just push that pin back in and put a drop of 290 loctite on it
 

·
Registered
Joined
·
5,028 Posts
BTW

welcome to KTOG and congrates on the new pistol

The new hammer blocks are on serial numbers greater than : JRW00
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Thanks for the welcome! I just put up my profile. I think you hit it on on the head. That was one of the things I was considering since it did not happen during rapid fire. It was my first day at the range with the P3AT (g2 by the way) and I was pulling the trigger back very slowly to get a feel for pull and accuracy. The reason I was concerned is because I just just gave back a Taurus Millenium Pro .40 that was at the factory longer than I had for trigger problems, and I thought, Not this again! LOL I did put 150 rounds through with no other mishaps Chambering and slide are a bit sticky but I am betting a bit more break in will loosen it up.
Thanks Mike
 

·
Registered
Joined
·
5,028 Posts
clean, LUBE, shoot and repeat.... ;)


It seems those that have glucks have the worse problem with the KT long pull and COMPLETE release trigger.


Sorry Got to run.....
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top