Community for Kel-Tec Shooters banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, I have a CP33 that has performed flawlessly until I recently put an adjustable trigger in it. Now after every shot the bolt locks back and I have to hold the bolt release down and cycle the bolt to load the next round. The only way to fire it semi auto is to hold down the bolt release lever while shooting. I can empty a full mag by manually cycling the bolt with no issues but when live firing it's one round at a time. Any idea what could be causing the bolt catch to hold after every shot?
 

·
Registered
cp33
Joined
·
14 Posts
You need to reset the spring in the plastic feed ramp back into the tiny hole in the bolt release lever inside, it should be putting tension downward on the release bar, and in turn the bolt catch. I'll post a pic once I find it. I specifically took a picture of mine when I did a Galloway trigger. Also make sure the release bar and bolt catch hook are interfacing properly, the bar should go into the crotch of the the hook and the little tail at the bottom of it.
 

·
Registered
cp33
Joined
·
14 Posts
You're welcome, hope that does the trick for you. This forum isn't the most active, and most of the posts are about feeding issues.

For me it was not a first try success situation either, I think I had the same issue the first time I reassembled. Actually, first time I missed the bar to release crotch interface, I had mine under instead of in between. I didn't do a full teardown when I did the trigger so the spring never popped out, but the second time a did a full teardown to paint the clamshell. clocking that spring around and getting it into the tiny hole in the bar was a pain.
 
1 - 5 of 5 Posts
Top