Community for Kel-Tec Shooters banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Kel tec sent me a new mag release and spring since my mag was dropping during firing with the plus one extension installed. Great customer service.... and the new mag release has a deeper shelf so it went in easily and looks like it will work great. The problem is, in putting my gun back together the trigger won't work and acts like its dragging on something. It appears to work fine with the frame out of the gun, but when I put the frame back in the gun the trigger won't function. What's up???
 

·
Registered
Joined
·
4,318 Posts
Possibly you did not get the hammer block back in place properly? When you put the frame back in the grip, you must leave the rear of frame up about 1/2 inch. The using some thin rod (the plastic ink container tube from a pen works well if it is empty) you have to push the hammer block all the way forward and gently push the rear of frame down until it semi crushes the ink tube. Then withdraw the tube and finish seating the frame flush. For illustrated instructions on this, visit the Northwoods Components website and check out the installation instructions from Pops on the aluminum trigger. These illustrations give a good run down with pictures on properly installing the frame back into the grip.

Jim R
 

·
Registered
Joined
·
5,203 Posts

·
Registered
Joined
·
250 Posts
Kel tec sent me a new mag release and spring since my mag was dropping during firing with the plus one extension installed. Great customer service.... and the new mag release has a deeper shelf so it went in easily and looks like it will work great. The problem is, in putting my gun back together the trigger won't work and acts like its dragging on something. It appears to work fine with the frame out of the gun, but when I put the frame back in the gun the trigger won't function. What's up???
Follow PF9Newbie's advice. This is common if you have never done a complete disassembly before. Good luck.
 

·
Registered
Joined
·
5,567 Posts
Sounds like the spring may not be in the trigger bar's groove where it belongs. Just a guess. The rear frame pin shouldn't have gone in if the hammer block wasn't pushed forward, mine wouldn't anyway.

Edit: I know it's a little late now but you don't have to remove the frame to replace the mag catch. You can just field strip the PF9 and us a very small flat head screw driver or pick and needle nose pliers. Instructions should be in the Disassembly and repair thread.
 

·
Registered
Joined
·
718 Posts
Sounds like the spring may not be in the trigger bar's groove where it belongs. Just a guess. The rear frame pin shouldn't have gone in if the hammer block wasn't pushed forward, mine wouldn't anyway.
Depending on where the hammer is during reassembly it is possible to get the rear pin in without having the hammer block reset. The problem I'm almost positive is the hammer block reset. Very easy to do with a small screwdriver or nail file.
 
1 - 6 of 6 Posts
Top