Community for Kel-Tec Shooters banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Issue description: I can't figure out what's wrong. Far as I can tell it seems to be binding on the mag release catch. I double checked assembly and everything looks right - bolt forward, dustcover aligned to rear, recoil tube tab at 12'clock. I insert the op handle, move it forward... There's a click as the bolt head goes over the mag catch... And then stuck. I have not forced it since I'm not sure. Firearm has had about 400 rounds through it. Model is su16ca from about 2006. Yeah, it's been a safe queen for a long time.

55940
 

·
Registered
Joined
·
370 Posts
Issue description: ... everything looks right - bolt forward, dustcover aligned to rear, recoil tube tab at 12'clock. I insert the op handle, move it forward... There's a click as the bolt head goes over the mag catch... And then stuck.
The 1. Bolt forward and 2. tube tab up are the key issues. You're getting it right, but it requires a little wiggling. You can tell how you're doing even before sending the carrier forward, while putting the charging handle in. Look at where the gas piston is pointing. It should be aligned well with the gas tube. There's a noticeable clank when everything falls into place.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
The 1. Bolt forward and 2. tube tab up are the key issues. You're getting it right, but it requires a little wiggling. You can tell how you're doing even before sending the carrier forward, while putting the charging handle in. Look at where the gas piston is pointing. It should be aligned well with the gas tube. There's a noticeable clank when everything falls into place.
Thanks! Yeah, I took it out and put it back in multiple times... real puzzler. The only thing I can think of is that maybe I knocked the mag catch loose or while cleaning it.. I dunno. It's not like I am a novice gun owner, but... beats me.

I called Kel Tec this morning. The smith looked at the same photo and said, nothing looks wrong... but then he said, "look, you have the very first model. there's been a lot of updates since then. Why do you send it back and we will do the updates for you too." Well I can't say no to that kind of customer support, so I'm boxing the rifle up tonight. Feels awfully silly sending a rifle back because I can't put it back together, but grateful for the help.
 

·
Registered
Joined
·
370 Posts
I called Kel Tec this morning. The smith looked at the same photo and said, nothing looks wrong... but then he said, "look, you have the very first model. there's been a lot of updates since then. Why do you send it back and we will do the updates for you too." Well I can't say no to that kind of customer support, so I'm boxing the rifle up tonight.
Maybe they'll find something broken. That said, I am not onboard with all of their updates. In particular, they deleted the dust cover in 2018 even on C and CA models. Mine never gave me any trouble. Also, I heard that barrels are no longer chrome-lined, although not sure how true that is.

I wish you took a photo from the right side, so that the position of the bolt were visible.
 
1 - 5 of 5 Posts
Top