Community for Kel-Tec Shooters banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Bought my SU-16 about two years ago. For the life of me I cannot get my rifle to fire. I have taken it apart and checked the bolt carrier assembly and everything looks ok outside of the rifle, however when the bolt carrier is in the rifle at no point can I get the firing pin to appear out of the front port of the bolt carrier.

From videos I have watched online the firing pin releases from the carrier with a simple pull by hand but I cannot get mine to release what so ever. I have tried tapping it out with a punch as well as using other various tools. Within the carrier the pin fully rotates and travels into the fully forward position when the assembly is removed and manipulated by hand.

I’m not sure if it’s the hammer, the firing pin or the entire bolt carrier assembly. I have tried contacting kel tec and they instructed me to try and diagnose the issue on my own before sending the gun back in to them. I know it’s a fairly simple gun, but I’m not a huge gunny so my knowledge is somewhat limited. Kel tec also told me to check here as they told me this was a great user based site. I was told the gun wouldn’t have been shipped from the plant had it not fired there. So I’m honestly out to lunch as to what the problem could be.

Really hoping you guys can help me with your depth of knowledge, if I have to order a new part or two that’s ok but I would like to fix it either way and hoping it’s just error on my part or something I’m just not seeing……

If you need more info that I have not mentioned, pictures or questions please ask and I will try to respond quickly.

I probably forgot to mention a bunch of stuff, sorry about that…….and thank you in advance for your knowledge, time, help and patience. Hope I can get this sorted.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi.
I am a brilliant Kel-Tec expert and I know exactly what to do!
Send it to Kel-Tec!

Im not being a smartallic, I mean it.
KT has a better repair dept than assembly dept.
I would but I can’t, due to the fact I live in Canada. Im not a licensed importer/exporter, so I can’t send or receive even a single screw or bolt across the border. I have to deal with a Canadian importer and repair centre that kel tec recommended (not really a big issue to me) but what really sticks in my craw is the company I purchased it from out of eastern Canada will have nothing to do with me since the purchase…….bunch of pricks of you ask me.

Was hoping I might get a few pointers here as the site came highly recommended to me and I wanted to deal with the issue on my own before giving up and sending the rifle out.

If it was up to me I would send it in to the manufacturer, I’ve heard kel tec is legendary for customer support and repairs. The guy I spoke with on the phone was super nice and great, but my countries gun laws are beyond restrictive and my government feels the need to protect us from ourselves a little too much. So I’m stuck with the options I have, which is deal with the problem on my own or mail it to a third party company that didn’t know a whole lot about my problem when I spoke to them over the phone.

Thanks for the input though I appreciate it.
 

·
Registered
Joined
·
6 Posts
Bought my SU-16 about two years ago. For the life of me I cannot get my rifle to fire. I have taken it apart and checked the bolt carrier assembly and everything looks ok outside of the rifle, however when the bolt carrier is in the rifle at no point can I get the firing pin to appear out of the front port of the bolt carrier.

From videos I have watched online the firing pin releases from the carrier with a simple pull by hand but I cannot get mine to release what so ever. I have tried tapping it out with a punch as well as using other various tools. Within the carrier the pin fully rotates and travels into the fully forward position when the assembly is removed and manipulated by hand.

I’m not sure if it’s the hammer, the firing pin or the entire bolt carrier assembly. I have tried contacting kel tec and they instructed me to try and diagnose the issue on my own before sending the gun back in to them. I know it’s a fairly simple gun, but I’m not a huge gunny so my knowledge is somewhat limited. Kel tec also told me to check here as they told me this was a great user based site. I was told the gun wouldn’t have been shipped from the plant had it not fired there. So I’m honestly out to lunch as to what the problem could be.

Really hoping you guys can help me with your depth of knowledge, if I have to order a new part or two that’s ok but I would like to fix it either way and hoping it’s just error on my part or something I’m just not seeing……

If you need more info that I have not mentioned, pictures or questions please ask and I will try to respond quickly.

I probably forgot to mention a bunch of stuff, sorry about that…….and thank you in advance for your knowledge, time, help and patience. Hope I can get this sorted.
Bought my SU-16 about two years ago. For the life of me I cannot get my rifle to fire. I have taken it apart and checked the bolt carrier assembly and everything looks ok outside of the rifle, however when the bolt carrier is in the rifle at no point can I get the firing pin to appear out of the front port of the bolt carrier.

From videos I have watched online the firing pin releases from the carrier with a simple pull by hand but I cannot get mine to release what so ever. I have tried tapping it out with a punch as well as using other various tools. Within the carrier the pin fully rotates and travels into the fully forward position when the assembly is removed and manipulated by hand.

I’m not sure if it’s the hammer, the firing pin or the entire bolt carrier assembly. I have tried contacting kel tec and they instructed me to try and diagnose the issue on my own before sending the gun back in to them. I know it’s a fairly simple gun, but I’m not a huge gunny so my knowledge is somewhat limited. Kel tec also told me to check here as they told me this was a great user based site. I was told the gun wouldn’t have been shipped from the plant had it not fired there. So I’m honestly out to lunch as to what the problem could be.

Really hoping you guys can help me with your depth of knowledge, if I have to order a new part or two that’s ok but I would like to fix it either way and hoping it’s just error on my part or something I’m just not seeing……

If you need more info that I have not mentioned, pictures or questions please ask and I will try to respond quickly.

I probably forgot to mention a bunch of stuff, sorry about that…….and thank you in advance for your knowledge, time, help and patience. Hope I can get this sorted.
Post some photos of the carrier group removed as a whole unit and then broken down from all angles out of the rifle. Show firing pin retention pin, bolt face and rear of carrier
Some photos of hammer face and hammer against carrier while in the rifle from the charging handle side.
 

·
Registered
Joined
·
6 Posts
Post some photos of the carrier group removed as a whole unit and then broken down from all angles out of the rifle. Show firing pin retention pin, bolt face and rear of carrier
Some photos of hammer face and hammer against carrier while in the rifle from the charging handle side.
The firing pin shouldn't freely rotate do to the retention pin, do you mean the bolt when you say it moves forward and rotates? To remove the bolt you need to remove the firing pin retention pin. Then remove the firing pin from the rear of the carrier. It should shake out easily. Then remove the bolt cam pin from the side of the carrier. It should pull out easily with your fingers. Then the bolt will come out the front. Each needs to be removed and replaced in sequence. The charging handle works to push the firing pin retention pin out. There is no force needed after the slight push of the firing pin retention pin, after that the parts should come out with little effort. Unless a piece of firing pin in jamming things. The firing pin should move freely back and forth so that it alternately protrudes slightly from the rear of the carrier where the hammer lands and the hole in the face of the bolt. If the firing pin randomly becomes stuck and won't move then I would guess a piece of the flared section of the firing pin broke off inside and is restricting movement. This would explain why the firing pin can't be removed. Once I remove the firing pin retention pin, my firing pin just falls out. I apologize if I ramble on. Get those photos up so everybody can have a look.
 
1 - 7 of 7 Posts
Top