Community for Kel-Tec Shooters banner
1 - 2 of 2 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
I had the bolt freeze up in the fully forward position yesterday.

I have a magazine of Buffalo Bore Outdoorsman 9mm +P that I had slipped into the gun for a woods walk. I loaded the first round in the magazine prior to the walk. Back at the truck I pulled the magazine and intended to shuck the round out of the chamber to put back in the magazine. I could not get the bolt to move.

I tried a few different positions to operate the bolt, the last step was putting the bolt handle on the edge of the pickup tailgate and pushing against that. I did not want to put any more force than that, figuring I was at risk of snapping off the bolt handle.

I thought about it a bit and reasoned that since the bolt was fully forward I had nothing to loose by just sending the round down range and see if that freed things up. That worked.

I could see no damage and afterwards the gun worked flawlessly with the plinking loads I had on hand.

My theory is that since the Buffalo Bore is a hard cast, unjacketed bullet with a flat nose it is possible that a bit of bullet was shaved as the top round was stripped from the magazine. That shaving was swaged against the cartridge case in the chamber as the bolt closed.

Does that sound likely? Any thing else I should be considering as a cause?
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #3 ·
Its almost brand new, Kel-Tec sent me a Gen 2 replacing a Gen 1 I had sent in for service. It probably has 300 rounds down the tube.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top