Community for Kel-Tec Shooters banner
1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
I am a working class guy.Berettas our out of my range.When a 9000s came up cheap new I jumped at it..It shot flawlessly.However when practicing clearing malfunctions unfired rounds did not eject.Low and behold it was the case hitting rim problem like my p3at.It was probably happening with fired rounds also but they did not get knocked off extractor the edge of the top round in mag was probably acting like an ejector.I sent it to Beretta twice for them to check it.THey even sent it back to me with the front site missing and could not fix.One procedure was adjusting extractor.Thats sounds like bs to me.How do you adj an extractor.So I got out the needle files and sandpaper and preformed the hood mod on it.Presto now if I get a dud round it will eject.My point being that some night when you are sitting around the campfire with the gun snobs telling you how great the big brand names are and how the kel tec types stink tell them about the "Beretta hood mod"before you punch them in the face(only kidding)
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
They repl the front site for me on the second trip.Its a dove tail and was sligtly loose but was in place when I first sent it in.It does amaze me that they could miss something like that when sending it back. >:(
 

·
Registered
Joined
·
726 Posts
bob said:
They repl the front site for me on the second trip.Its a dove tail and was sligtly  loose but was in place when I first sent it in.It does amaze me that they could miss something like that when sending it back. >:(
My guess would be that it would have been hard to miss (pun intended) if they had test fired it before being returned...............

I did have a rear sight fly off during an IPSC match once. :(

wyo-man
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top