Anyone else seem to have this mag problem??

Discussion in 'P-3AT' started by coltc, Dec 24, 2007.

  1. coltc

    coltc New Member

    5
    Dec 23, 2007
    Don't know if this is common or if it's just me. The two pics below are of two of my p3at mags.

    The first one has two triangular pieces missing out of the back of the mag. One piece missing on each side. Then it is cracked down a little bit off of the bottom of the missing pieces.

    The second one has two cracks where the first mag has the pieces missing. You can tell where the crack is on the right side but the light glare. Sorry the pics kinda suck but my camera doesn't take the best up close pics, or I don't know how anyway...

    Don't use either of them because they will no longer hold the mag follower in. Are the mags covered under the lifetime warranty? Just wondering even though I already bought a couple more. Any reasons as to the cause of this?

    [​IMG]

    [​IMG]
     
  2. PshootR

    PshootR Banned

    Apr 1, 2005
    Send 'em to Kel-Tec and I'm sure they'll send you 2 new ones.
    Mags are heat treated at the top so that the feed lips do not spread out in use. Yours prolly got a little too much heat and the steel became brittle and then cracked.

    PshootR
     

  3. rcmodel

    rcmodel New Member

    Feb 6, 2005
    Eastern Kansas
    That is caused by the barrel feed-ramp driving rounds back into the magazine under recoil.
    If you do the "Smiley Test" you will find the source of the problem.

    If you do the "Smiley Fix" you won't break anymore magazines.

    http://www.1bad69.com/keltec/smiley.htm

    rcmodel
     
  4. fcernese

    fcernese New Member

    23
    Mar 1, 2005
    Has KelTec commented on this problem? Does it exist in the 2nd generation as well?

     
  5. coltc

    coltc New Member

    5
    Dec 23, 2007
    Thank you!! That's exactly it!! Looking into fixing it now...


    I think I'll contact Kel-Tec about replacing the mags after the holidays. Glad to see it wasn't caused by me somehow.