Come help us Launch CZTalk.com - Free Decals!
KTOG - Kel Tec Owners Group Forum > KelTec Products > P-3AT > P3AT Feed problem



Reply
 
LinkBack Thread Tools Display Modes
Old 08-25-2012, 09:44 PM   #1
thomwilt
 
Join Date: Jul 2012
Posts: 6
Default P3AT Feed problem

On the range, P3AT wasn't feeling 'smooth'. At about 40 rounds, (WWB,fmj)feeding problems started. Cycling rounds by hand, they're hanging up. Everything is clean, about 1200 rounds through it with only minor issues. (At about 200 rnds, FTE's) Do I just need to polish the feed ramp or is this a sign of deeper probs? (2 factory mags, same symptoms)
TIA



__________________
thomwilt is offline  
 
Reply With Quote Quick reply to this message
Old 08-26-2012, 01:03 AM   #2
Toney_D
Grand Poobah
 
Toney_D's Avatar
 
Join Date: Aug 2010
Location: Oklahoma
Posts: 3,302
Liked 74 Times on 68 Posts
Likes Given: 62

Default

I would not shoot WWB if it was free!!!

It would'nt hurt to polish your ramp, but i would clean and lube it and try different ammo.



__________________

P32

Toney_D is offline  
 
Reply With Quote Quick reply to this message
Old 08-26-2012, 03:56 PM   #3
TxCajun
Administrator
KOG_ADMIN.png
 
TxCajun's Avatar
 
Join Date: Sep 2004
Location: Texas
Posts: 30,122
Liked 206 Times on 175 Posts
Likes Given: 8

Default

Quote:
Originally Posted by thomwilt View Post
On the range, P3AT wasn't feeling 'smooth'. At about 40 rounds, (WWB,fmj)feeding problems started. Cycling rounds by hand, they're hanging up.
The flat-nosed WWB does not feed well for some. Try several other good quality, brass-cased brands of ammo. Also, see comment below on round count.

Quote:
Originally Posted by thomwilt View Post
...At about 40 rounds, (WWB,fmj)feeding problems started.... Everything is clean, about 1200 rounds through it with only minor issues.
Everything is not clean after 40 rounds. These ultra-lights are not high round count weapons. I would not often shoot 40 rounds in a session, at least not without anticipating some possible issues as the gun gets dirty. (WWB is pretty dirty crappola.) Many veteren owners, if they shoot more than a few mags per session, will clean and lube every 50 or so rounds.

Quote:
Originally Posted by thomwilt View Post
(At about 200 rnds, FTE's)
Again, this gun is absolutely not meant to shoot 200 rounds in a session. If you insist on abusing like that, you'd need to clean and lube it several times. This is an ultralight, niche weapon, optomized for concealed carry. It is not a 2 pound duty weapon meant for that level of abuse. Learn how to use and care for it, or expect to have problems.

You might polish the feedramp.
http://goldenloki.com/gunsmith/keltec/fullrp.htm

Make sure the gun is cleaned and well lubed.
http://goldenloki.com/gunsmith/keltec/lube.htm

But seriously, I am hesitant to suggest any "fixes" as your problems seem mostly self-induced. When I go to the range, my P3AT gets a couple mags of carry ammo to confirm reliability. I do my range blasting with other guns that were meant for that purpose.

Look at your P3AT. It is obviously not designed as a range blaster, target gun, plinker or anything but a mass-produced, inexpensive, ultra-light pistol, designed to be carrried anytime, anywhere, and to dump a mag to save your bacon under the most extreme of emergencies. Treat it like that and it will do it's job. Treat it otherwise at your own peril.


Note: Thread moved to proper forum (P3AT).
__________________
Patriotism is supporting your country all the time and your government when it deserves it.
- Mark Twain




P32, P32NAA, P3AT, PF9, P11/40/357Sig, Sub2K9, Sub9, SU16C + More to come.
TxCajun is online now  
 
Reply With Quote Quick reply to this message
Old 08-26-2012, 10:27 PM   #4
P32Jake
Grand Poobah
 
P32Jake's Avatar
 
Join Date: Jan 2011
Location: Salt Lake Valley
Posts: 715
Liked 35 Times on 32 Posts
Likes Given: 5

Default

Quote:
Originally Posted by thomwilt
On the range, P3AT wasn't feeling 'smooth'. At about 40 rounds, (WWB,fmj)feeding problems started. Cycling rounds by hand, they're hanging up. Everything is clean, about 1200 rounds through it with only minor issues. (At about 200 rnds, FTE's) Do I just need to polish the feed ramp or is this a sign of deeper probs? (2 factory mags, same symptoms)
TIA
On both my p32 and 3at, my range session consists of a total of about 30 rounds. I shoot two mags (1 high cap, one standard) of my SD ammo and then about 25 rounds of fmj range ammo. That is it, and I do it about every 4 months or so. Never have any problems. I have shot more of the p32 before with no problems (never shot mote than 100 rounds at a time though), but my gen1 p3at gets hot fast and will start to FTE after about 50 rounds if I shoot to fast and it gets too hot.
__________________

Gen1 P32w/pocket clip
Gen1 P3ATw/pocket clip
P11 w/P40 conversion
Soon to be PF9!

P32Jake is offline  
 
Reply With Quote Quick reply to this message
Old 08-27-2012, 05:04 PM   #5
gasem
 
Join Date: Jun 2012
Location: FL home of KELTEC CNC
Posts: 89
Liked 6 Times on 6 Posts
Likes Given: 1

Default

I normally shoot 50 rounds on a trip to the range. I've had minor issues with wwb ftf but no problem with the freedom munitions flat nose round which has a less drastic truncated profile. My gun functions better with a bit hotter round like the remington umc or the freedom munitions ammo. I switched to TW25b grease as my lube and MC25 as my cleaning solution. This grease does not easily disolve the products of combustion which I think is responsible for a lot of fouling. When I clean, the carbon is more "on" the grease not "in" the grease. Not saying this is some kind of magic grease, just that my guns runs better since I started using it. I use a thin layer everywhere except the extractor. I did take the frame out and put some on or in every that rubs, trigger, hammer, hammer block springs pins etc.

__________________
gasem is offline  
 
Reply With Quote Quick reply to this message
Old 09-02-2012, 05:07 PM   #6
slingshot1
 
Join Date: Aug 2012
Posts: 5
Default

Quote:
Originally Posted by thomwilt View Post
On the range, P3AT wasn't feeling 'smooth'. At about 40 rounds, (WWB,fmj)feeding problems started. Cycling rounds by hand, they're hanging up. Everything is clean, about 1200 rounds through it with only minor issues. (At about 200 rnds, FTE's) Do I just need to polish the feed ramp or is this a sign of deeper probs? (2 factory mags, same symptoms)
TIA
I had this problem with my P3AT almost right out of the box. Fortunately for me, I live about 25 minutes from Kel-Tec in Cocoa, FL, so drove to their repair shop. They did the repair while I waited and it has functioned flawlessly since. They polished the loading ramp, replaced the barrel and did a trigger upgrade, whatever that was. It is now valued as a personal defense weapon and I wouldn't part with it. IMO If your problem persists, don't wait, send it to the repair shop and you will be more than satisfied with the result.
__________________
slingshot1 is offline  
 
Reply With Quote Quick reply to this message
Old 09-16-2012, 09:59 PM   #7
sjmclean
 
Join Date: Feb 2011
Posts: 3
Default

My P3AT suffered from FTE right out of the box. I had three brands of ammo on hand and none would empty a magazine with out Failure To Extract and eject. It got worse until I sent it to the factory for repair. Over 150 rounds so far with no problems. I rarely shoot more than 18 rounds at a time since this not a target gun or a "blaster". It is for daily discreet carry that may save a life. I have no gripes over this "problem" as I have more expensive pistols that have been much more difficult to make reliable (C-O-L-T).



__________________
sjmclean is offline  
 
Reply With Quote Quick reply to this message
Reply


Quick Reply
Message:
Options

Go Back   KTOG - Kel Tec Owners Group Forum > KelTec Products > P-3AT

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro-Mag 15 round feed problem Cheesehead P-11 & P-40 5 03-27-2012 10:19 PM
New S2K 9mm feed problem anyone have it? Maurice419 Sub9 and Sub2000 Rifles 1 01-26-2010 03:37 PM
P 11 Feed problem Sir_Bug P-11 & P-40 11 05-22-2008 01:42 PM
Feed problem mkamer P-32 10 07-06-2005 06:01 PM
1st Gen. P3AT: Odd feed problem. mini14jac P-3AT 19 05-27-2005 06:21 PM